AVCP non si attiva e blocca l’admin

Home Forum Pubblica Amministrazione ANAC XML Bandi di Gara AVCP non si attiva e blocca l’admin

Taggato: , ,

Stai visualizzando 15 post - dal 1 a 15 (di 16 totali)
  • Autore
    Post
  • #405
    Nicola
    Amministratore del forum

    Ciao Marco, ho provato ad installare il tuo plugin AVCP sul sito:
    http://www.fermimontesarchio.it con WP 3.3.1.
    L’istallazione va a buon fine ma NON l’attivazione.
    Dopo aver dato il comando Attiva plugin viene fuori una pagina bianca e tutto l’admin si impalla, praticamente non è più possibile accedere all’admin (pagina bianca). Risolvo solo entrando con l’FTP e cancellando la cartella AVCP.
    Ho provato con Amministrazione trasparente ed è identica storia.
    Cos’è che non va?

    #407
    Marco Milesi
    Amministratore del forum

    Ciao,
    purtroppo per capire il problema dovrei fare delle prove “sul campo”, vista la versione abbastanza datata che usi.

    Non hai la possibilità di aggiornare a WordPress 3.8? Fai un backup del database e di file nello spazio ftp e lancia l’aggiornamento. Ne guadagnerai in sicurezza, stabilità e compatibilità!

    Fammi sapere!

    A Presto

    #447
    Nicola
    Amministratore del forum

    L’ho fatto tempo fa, ma fu un fallimento, il sito non funzionava più, dovetti riuploadare tutto il backup fatto (per fortuna). Da allora ho rinunciato. Io non conosco php, per cui non posso fare modifiche.
    Se volessi installare manualmente il plugin? Richiederebbe comunque l’attivazione tramite pannello?

    #451
    Marco Milesi
    Amministratore del forum

    Si, l’unico modo per utilizzare un plugin WordPress è attivarlo. Fino a quando non è attivato, WP non carica i suoi file.

    Comunque, tenta nuovamente l’aggiornamento… Quale Hosting usi?

    #461
    Nicola
    Amministratore del forum

    Sono riuscito ad aggiornarte wp alla 3.8, ho installato il plugin ma mi segnala una serie di errori ai quali non so dare soluzione. Rinuncio, ma tu vai avanti.

    #464
    Marco Milesi
    Amministratore del forum

    Credo che gli errori a cui ti riferisci siano quelli della validazione dei dataset… Controlla i dati che hai inserito nelle gare (codici fiscali a caso o cose simili).

    PS. Complimenti per avere aggiornato 😉

    #510
    Nicola
    Amministratore del forum

    Grande! Reinstallato e tutto ok, per ora (perchè è tutto vuoto, non ho ancora inserito nè ditte nè bandi).
    L’errore veniva fuori perchè nella root era già presente un applicativo simile (non plugin) con cartella AVCP e quindi faceva casini con i file già presenti.
    Ho creato il dataset, e dopo una segnalazione errori e ridato il comando crea dataset è andato tutto a posto. Non resta che vedere come si comporta sul campo.
    Unico problema:
    L’url al quale si visualizzano i file è questo:
    http://www.fermimontesarchio.it/wpfermi/avcp/
    Però il sito è impostato per vedere la root all’indirizzo:
    http://www.fermimontesarchio.it/
    e non
    http://www.fermimontesarchio.it/wpfermi/
    come si rileva dal link presente nella pagina (sulla cartella o in “Torna al sito), producendo un errore 404.
    E’ possibile da qualche parte impostare per questi link il percorso giusto?
    In caso di altri problemi, poi, ti scoccerò ancora.
    Per adesso ti faccio i miei complimenti per l’applicativo.

    #532
    Marco Milesi
    Amministratore del forum

    No, non è possibile cambiare quell’indirizzo con gli strumenti presenti nel plugin di AVCP.

    Il plugin prende semplicemente il campo “Indirizzo WordPress (URL)” configurato in Impostazioni -> Generali.

    Comunque non lo vedo come un problema grave, visto che quella pagina in sè non ha alcun valore: avcp richiede l’url diretto dei file .xml e gli utenti “normali” non credo siano interessati ai dataset (se non mi sbaglio non è neanche un obbligo l’accesso pubblico ai dataset).
    Quella pagina serve più per facilitare il rintracciamento dei file .xml per chi gestisce il sito, così come per avere la certezza che tutti i dataset sono stati creati (sempre per semplificare l’ambito “back-office”).
    Hai qualche perplessità, idea o necessità in merito?

    #569
    Nicola
    Amministratore del forum

    Si, credo tu abbia ragione, in fondo quella è una pagina di servizio.

    Ultima cosa (almeno fino a che non si inizierà ad inserire i dati): alla pagina:

    http://www.fermimontesarchio.it/contratti-pubblici/

    come vedi c’è un “Errore Query” all’inizio della tabella. E’ perchè non è inserito ancora alcun dato?

    #585
    Marco Milesi
    Amministratore del forum

    Sisi: nessuna gara = errore query 🙂

    #622
    Nicola
    Amministratore del forum

    Ciao Marco, ok, capito.

    Non so se attivare un nuovo topic o meno per farti una nuova domanda, provo qui:

    Il DSGA ha messo mano alla sezione admin di AVCP ma, effettivamente, non troviamo da nessuna parte il modo di inserire ditte, solo gare, e con una quantità di dati caratterizzante che sembra alquanto povera (CIG, importi, nome della gara). Come si inseriscono le ditte?

    #638
    Marco Milesi
    Amministratore del forum

    Ciao,

    si inseriscono da AVCP -> DITTE -> NUOVA DITTA

    https://www.youtube.com/watch?v=D_nmx_XXo8o

    Se utilizzi ruoli particolari per l’utente, questo menù potrebbe non comparire (puoi comunque provare con l’utente amministratore). Appena  possibile il problema dei ruoli sarà risolto!

     

    #662
    Nicola
    Amministratore del forum

    Come sempre… hai ragione tu! ;-))

    Infatti quando entro come amministratore vedo tutte le voci, ma nel suo caso… non riesco ad uscirne, con i ruoli.

    Ho installato i seguenti plugin per gestire i ruoli (per limitare i menu visibili ad un autore nella barra dell’admin):

    – Members

    – Role Scoper

    – Adminimize

    Ma evidentemente qualcosa confligge, perchè per quell’utente non si vedono tutte le voci di AVCP.

    Sto pensando di disinstallare tutti questi plugin di gestione dei ruoli e cercarne uno solo che faccia quello che voglio, cioè mostrare per il singolo autore solo determinate voci nella barra dell’admin.

    Me ne sai consigliare uno compatibile con AVCP?

     

    #664
    Marco Milesi
    Amministratore del forum

    AVCP, al momento, non mappa le “meta-capacità”, quindi non viene riconosciuto da questo tipo di plugin. Appena possibile lo rendo uguale al plugin Amministrazione Trasparente, che ha un’opzione appunto per mapparle (non lo rendo di default perchè una volta mappate vanno impostate da 0).

    Comunque ti consiglio MAP-CAP (se vuoi qualcosa di semplice, funzionale e configurabile in 20 secondi) o MEMBERS (che richiede molto più tempo per essere configurato, ma è completissimo)

    #673
    Nicola
    Amministratore del forum

    Provati, ma non funzionano, nel senso che il menù AVCP viene visualizzato all’utente senza le voci DITTE, IMPOSTAZIONI e VALIDAZIONE.

    Ho parzialmente risolto inserendo la funzione seguente in “functions.php” del mio tema:

    add_action( ‘admin_init’, ‘my_remove_menu_pages’ );
    function my_remove_menu_pages() {
    global $userdata;
    get_currentuserinfo();

    if ($userdata->ID == 7) {
    remove_menu_page(‘edit.php’);

    …e così via per le varie voci del menu di wp

    Unico problema è che non toglie le voci di menù relative ai plugin installati,

    ad esempio: remove_menu_page(‘edit.php?post_type=slideshow’); non funziona, ma almeno ho nascosto le voci più delicate.

     

     

Stai visualizzando 15 post - dal 1 a 15 (di 16 totali)
  • Il topic ‘AVCP non si attiva e blocca l’admin’ è chiuso a nuove risposte.

Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

Chiudi