Come reindirizzare ad una pagina

Home Forum Pubblica Amministrazione Amministrazione Trasparente Come reindirizzare ad una pagina

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Autore
    Post
  • #2899
    Paolo Zanetti
    Partecipante

    Ciao Marco, mi associo anch’io ai doverosi complimenti espressi da tutti per il tuo lavoro.

    Sto studiando il plugin per organizzare le informazioni ed inserirle nel sito di una scuola.
    Il mio obiettivo è quelllo di creare una sezione dove nella sidebar di sinistra compaia il sommario e nella pagina il contenuto della sezione desiderata come pagina e non come articolo.
    Per fare questo ho provato ad utilizzare il reindirizzamento automatico dell’articolo verso una pagina. Vedo, però, che questo non funziona. Quando io seleziono la voce che dovrebbe indirizzare, in realtà, mi si apre una pagina che mostra l’articolo (che non ha testo ma solo titolo e tipologia assegnata) e con un indice nella sidebar differente e contenente anche la lista esplosa di tutte le sezioni.
    Dove sbaglio?

    Ti do le url per verificare quanto descritto:

    Grazie mille!

    • Questo topic è stato modificato 7 anni, 3 mesi fa da Paolo Zanetti.
    #2901
    Marco Milesi
    Amministratore del forum

    Ciao Paolo,
    il comportamento della barra di sinistra dovrebbe dipendere esclusivamente dal tema e da come vengono gestiti gli widget nelle “sidebar”.

    Per quanto riguarda le sezioni e voci tieni presente che il reindirizzamento agisce a livello di articolo e non di archivio di articoli. Quindi entri in “Programma per …”, vedi un solo articolo (che al momento non ha titolo ma nulla vieta di dargliene uno) e solo cliccando per aprire questo articolo si ottiene il reindirizzamento.

    La logica utilizzata è quella di archivi/articoli anziché pagine/sottopagine, ed è anche quella, a mio modo di vedere, più giusta e rispondente alla normativa (es. archiviazione quinquennale,…)

    #2902
    Paolo Zanetti
    Partecipante

    Ciao Marco, ti ringrazio. E’ chiaro.

    Ti faccio un’ultima domanda: perchè l’articolo che si apre da un link dell’indice contiene “Tipologia Archives: ” nel titolo?
    Il tema che utilizzo è Edu, ma se pubblico un nuovo articolo il titolo non contiene questa aggiunta.
    Come posso toglierla?

    Grazie ancora

    Paolo

    #2903
    Marco Milesi
    Amministratore del forum

    Ciao,
    dipende esclusivamente dal tema. Credo che la soluzione più semplice sia quella di rimuovere tale dicitura dal file che la genera (potenzialmente archive.php o taxonomy.php).

    PS. Sul sito ci sono problemi con le voci espandibili nella sidebar (mea culpa?), mentre in un altro widget hai racchiuso lo shortcode nei tag <code> e </code> rovinandone parzialmente la visualizzazione (probabilmente copiando e incollando da questo sito).

    • Questa risposta è stata modificata 7 anni, 3 mesi fa da Marco Milesi.
    #2909
    Paolo Zanetti
    Partecipante

    Ciao Marco, haimè sto cominciando ad incartarmi.
    Vado in ordine

    • la dicitura del titolo non riesco a toglierla anche perchè non ho trovato i file archive.php o taxonomy.php nel tema. Peraltro, in tutti gli articoli estenri ad AT non si verifica: incomaptibilità del tema?
    • le voci espandibili appaiono così quando selezione voci espandibili nel widget
    • l’utilizzo di <code/code> ho visto che è necessario per avere la visualizzazione su due colonne con la formattazione dei titoli delle sessioni ed il totale dei contenuti inseriti. A mo di esempio puoi vedere:

      http://www.valconi.it/content/at-1/, dove ho inserito il [at-sezioni col=”3″ bar=”2″ con=”1″]
      http://www.valconi.it/content/at-2, dove ho inserito [at-sezioni col="3" bar="2" con="1"]
      http://www.valconi.it/content/at-3, dove ho inserito

      [at-sezioni col="3" bar="2" con="1"]

      Come puoi vedere, nessuna delle tre visualizzazioni è soddisfacente

    Ciao

    Paolo

    • Questa risposta è stata modificata 7 anni, 3 mesi fa da Paolo Zanetti.
    #2929
    Marco Milesi
    Amministratore del forum

    Purtroppo il tema, essendo Premium, non ho modo di verificarlo. Ti conviene chiedere direttamente agli sviluppatori del tema. Idem per il widget, che però come lo hai messo adesso lo preferirei.

    Per quanto riguarda lo shortcode, prova a riscriverlo a mano. Ad esempio il primo che hai messo non funziona perché le virgolette non sono quelle richieste (usa quelle sopra il tasto 2).

    A presto

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Devi essere connesso per rispondere a questo topic.

Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

Chiudi