Installazione plugin spid wordpress - errore saml • WPGov.it

Home Forum Plugins SPID Installazione plugin spid wordpress – errore saml

Questo argomento contiene 1 risposta, ha 2 partecipanti, ed è stato aggiornato da  Marco Milesi 1 mese, 2 settimane fa.

Stai vedendo 2 articoli - dal 1 a 2 (di 2 totali)
  • Autore
    Articoli
  • #4029

    Virgilio Riccardo
    Partecipante

    Salve,
    Abbiamo seguito la procedura per installazione e configuraione di spid su wordpress, il tutto è avanzato come da guida ad eccezione del passaggio in cui vedevamo i metadati.
    Dopo aver cliccato du federazione e mostra metadati abbiamo ottenuto la seguente eccezione:
    SimpleSAML_Error_Error: UNHANDLEDEXCEPTION

    Backtrace:
    1 www/_include.php:45 (SimpleSAML_exception_handler)
    0 [builtin] (N/A)
    Caused by: SimpleSAML_Error_Exception: authsources[‘default-sp’]: Could not find PEM encoded certificate in “/home/cydcsheh/comune.thinkwebstudio.com/wp-content/spid/cert/saml.crt”.
    Backtrace:
    3 lib/SimpleSAML/Configuration.php:1338 (SimpleSAML_Configuration::getPublicKeys)
    2 lib/SimpleSAML/Utils/Crypto.php:210 (SimpleSAML\Utils\Crypto::loadPublicKey)
    1 modules/saml/www/sp/metadata.php:115 (require)
    0 www/module.php:135 (N/A)

    Mentre questa è l’eccezzione che viene generata se si testa l’accesso con uno dei gestori:

    SimpleSAML_Error_Error: UNHANDLEDEXCEPTION

    Backtrace:
    1 www/_include.php:45 (SimpleSAML_exception_handler)
    0 [builtin] (N/A)
    Caused by: SimpleSAML_Error_Exception: authsources[‘default-sp’]: Could not find PEM encoded certificate in “/home/cydcsheh/comune.thinkwebstudio.com/wp-content/spid/cert/saml.crt”.
    Backtrace:
    8 lib/SimpleSAML/Configuration.php:1338 (SimpleSAML_Configuration::getPublicKeys)
    7 lib/SimpleSAML/Utils/Crypto.php:210 (SimpleSAML\Utils\Crypto::loadPublicKey)
    6 modules/saml/lib/Message.php:34 (sspmod_saml_Message::addSign)
    5 modules/saml/lib/Message.php:105 (sspmod_saml_Message::addRedirectSign)
    4 modules/saml/lib/Message.php:476 (sspmod_saml_Message::buildAuthnRequest)
    3 modules/saml/lib/Auth/Source/SP.php:190 (sspmod_saml_Auth_Source_SP::startSSO2)
    2 modules/saml/lib/Auth/Source/SP.php:335 (sspmod_saml_Auth_Source_SP::startSSO)
    1 modules/saml/www/sp/discoresp.php:28 (require)
    0 www/module.php:135 (N/A)

    #4032

    Marco Milesi
    Amministratore del forum

    Buongiorno,
    probabilmente è un problema di generazione di certificati e andrebbe rifatta la procedura di installazione del plugin.
    Purtroppo data la complessità del sistema, non è possibile dare una soluzione certa in quanto dipende molto dalla configurazione del server.
    In caso di ulteriori problemi può contattarmi anche tramite email.
    A presto,
    Marco

Stai vedendo 2 articoli - dal 1 a 2 (di 2 totali)

Devi essere loggato per rispondere a questa discussione.

Vai alla barra degli strumenti

Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

Chiudi